use strict;
my $str = 'abc 1 2 3 abc';
my $regex = qr/(\d[\d\s]*)(?=\s+)/p;
my $subst = '<b>$1</b>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";