const regex = /(\d[\d\s]*)(?=\s+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d[\\d\\s]*)(?=\\s+)', 'g')
const str = `abc 1 2 3 abc`;
const subst = `<b>$1</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);