# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(LIF|LPA) ?\d{1,2}.\d{1,2}(\.\d{1})?/QuestionText = "$1",/gim;t' <<< "LIF 1.2 Both
LIF 2.7.1 Address Line 1
LIF 4.13 Occupation
LIF 10.6.1 Address Line 1
LPA0.1 What type of LPA do you want?
LPA0.2 Do you have same attorneys with your partner ?"