import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(LIF|LPA) ?\\d{1,2}.\\d{1,2}(\\.\\d{1})?";
final String string = "LIF 1.2 Both\n"
+ "LIF 2.7.1 Address Line 1\n"
+ "LIF 4.13 Occupation\n"
+ "LIF 10.6.1 Address Line 1\n"
+ "LPA0.1 What type of LPA do you want?\n"
+ "LPA0.2 Do you have same attorneys with your partner ?";
final String subst = "QuestionText = \"$1\",";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}