import Foundation
let pattern = #"(LIF|LPA) ?\d{1,2}.\d{1,2}(\.\d{1})?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
LIF 1.2 Both
LIF 2.7.1 Address Line 1
LIF 4.13 Occupation
LIF 10.6.1 Address Line 1
LPA0.1 What type of LPA do you want?
LPA0.2 Do you have same attorneys with your partner ?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"QuestionText = "$1","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)