using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(LIF|LPA) ?\d{1,2}.\d{1,2}(\.\d{1})?";
string substitution = @"QuestionText = ""$1"",";
string input = @"LIF 1.2 Both
LIF 2.7.1 Address Line 1
LIF 4.13 Occupation
LIF 10.6.1 Address Line 1
LPA0.1 What type of LPA do you want?
LPA0.2 Do you have same attorneys with your partner ?";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}