import re
regex = re.compile(r"time=+([0-9]*.[0-9]{2})")
test_str = "28 bytes from 173.194.116.216: icmp_seq=5 ttl=57 time=22.882 ms"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")