re = /time=+([0-9]*.[0-9]{2})/
str = '28 bytes from 173.194.116.216: icmp_seq=5 ttl=57 time=22.882 ms'
# Print the match result
str.match(re) do |match|
puts match.to_s
end