import Foundation
let pattern = #"time=+([0-9]*.[0-9]{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"28 bytes from 173.194.116.216: icmp_seq=5 ttl=57 time=22.882 ms"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}