#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(profiles|id)\/([\w-]*)"
Local $sString = "https://steamcommunity.com/id/rafa_br34/" & @CRLF & _
"https://steamcommunity.com/id/rafa_br34/allcomments" & @CRLF & _
"https://steamcommunity.com/profiles/76561198449824687/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")