package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(profiles|id)\/([\w-]*)`)
var str = `https://steamcommunity.com/id/rafa_br34/
https://steamcommunity.com/id/rafa_br34/allcomments
https://steamcommunity.com/profiles/76561198449824687/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}