$re = '/(profiles|id)\/([\w-]*)/m';
$str = 'https://steamcommunity.com/id/rafa_br34/
https://steamcommunity.com/id/rafa_br34/allcomments
https://steamcommunity.com/profiles/76561198449824687/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);