import re
regex = re.compile(r"(profiles|id)\/([\w-]*)", flags=re.MULTILINE)
test_str = ("https://steamcommunity.com/id/rafa_br34/\n"
"https://steamcommunity.com/id/rafa_br34/allcomments\n"
"https://steamcommunity.com/profiles/76561198449824687/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")