import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(profiles|id)\\/([\\w-]*)";
final String string = "https://steamcommunity.com/id/rafa_br34/\n"
+ "https://steamcommunity.com/id/rafa_br34/allcomments\n"
+ "https://steamcommunity.com/profiles/76561198449824687/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}