re = /(profiles|id)\/([\w-]*)/m
str = 'https://steamcommunity.com/id/rafa_br34/
https://steamcommunity.com/id/rafa_br34/allcomments
https://steamcommunity.com/profiles/76561198449824687/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end