# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([1-9](?:\s*[0-9]){3})\s?([A-Z])(?i:\2*)\s*([A-Z])(?i:\3*)\b/$1$2$3/mg;t' <<< "1 2 3 4 Alpha Bravo
1234 Alpha Bravo
1234A Bbbbbbbc
1234Aaa Bbb
1234Aa Bbb
1234A BbbbBbbbb"