#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b([1-9](?:\s*[0-9]){3})\s?([A-Z])(?i:\2*)\s*([A-Z])(?i:\3*)\b"
Local $sString = "1 2 3 4 Alpha Bravo" & @CRLF & _
"1234 Alpha Bravo" & @CRLF & _
"1234A Bbbbbbbc" & @CRLF & _
"1234Aaa Bbb" & @CRLF & _
"1234Aa Bbb" & @CRLF & _
"1234A BbbbBbbbb"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)