# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b([1-9](?:\s*[0-9]){3})\s?([A-Z])(?i:\2*)\s*([A-Z])(?i:\3*)\b"
test_str = ("1 2 3 4 Alpha Bravo\n"
"1234 Alpha Bravo\n"
"1234A Bbbbbbbc\n"
"1234Aaa Bbb\n"
"1234Aa Bbb\n"
"1234A BbbbBbbbb")
subst = "$1$2$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.