const regex = /\b([1-9](?:\s*[0-9]){3})\s?([A-Z])(?i:\2*)\s*([A-Z])(?i:\3*)\b/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([1-9](?:\\s*[0-9]){3})\\s?([A-Z])(?i:\\2*)\\s*([A-Z])(?i:\\3*)\\b', 'mg')
const str = `1 2 3 4 Alpha Bravo
1234 Alpha Bravo
1234A Bbbbbbbc
1234Aaa Bbb
1234Aa Bbb
1234A BbbbBbbbb`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);