$re = '/\b([1-9](?:\s*[0-9]){3})\s?([A-Z])(?i:\2*)\s*([A-Z])(?i:\3*)\b/m';
$str = '1 2 3 4 Alpha Bravo
1234 Alpha Bravo
1234A Bbbbbbbc
1234Aaa Bbb
1234Aa Bbb
1234A BbbbBbbbb';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;