using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([1-9](?:\s*[0-9]){3})\s?([A-Z])(?i:\2*)\s*([A-Z])(?i:\3*)\b";
string substitution = @"$1$2$3";
string input = @"1 2 3 4 Alpha Bravo
1234 Alpha Bravo
1234A Bbbbbbbc
1234Aaa Bbb
1234Aa Bbb
1234A BbbbBbbbb";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}