# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^[^"]*(?:"[^"]*"[^"]*)*)\r?\n/|\n/g;t' <<< "abcd
ef\"gh
ijk
lm\"no
pqrs
tu\"vw
xyz
ab\"cd
"