using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^[^""]*(?:""[^""]*""[^""]*)*)\r?\n";
string substitution = @"|\n";
string input = @"abcd
ef""gh
ijk
lm""no
pqrs
tu""vw
xyz
ab""cd
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}