import Foundation
let pattern = #"(?<=^[^"]*(?:"[^"]*"[^"]*)*)\r?\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
abcd
ef"gh
ijk
lm"no
pqrs
tu"vw
xyz
ab"cd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)