import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^[^\"]*(?:\"[^\"]*\"[^\"]*)*)\\r?\\n";
final String string = "abcd\n"
+ "ef\"gh\n"
+ "ijk\n"
+ "lm\"no\n"
+ "pqrs\n"
+ "tu\"vw\n"
+ "xyz\n"
+ "ab\"cd\n";
final String subst = "|\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}