re = /(?<=^[^"]*(?:"[^"]*"[^"]*)*)\r?\n/
str = 'abcd
ef"gh
ijk
lm"no
pqrs
tu"vw
xyz
ab"cd
'
subst = '|\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result