use strict;
my $str = 'abcd
ef"gh
ijk
lm"no
pqrs
tu"vw
xyz
ab"cd
';
my $regex = qr/(?<=^[^"]*(?:"[^"]*"[^"]*)*)\r?\n/p;
my $subst = '|\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";