$re = '/(?<=^[^"]*(?:"[^"]*"[^"]*)*)\r?\n/';
$str = 'abcd
ef"gh
ijk
lm"no
pqrs
tu"vw
xyz
ab"cd
';
$subst = "|\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;