#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9a-f]{8}(?:\-[0-9a-f]{4}){3}-[0-9a-f]{12}$"
Local $sString = "019311e8-3ff1-718c-bb3d-cbe7211d3bb9" & @CRLF & _
"019311f0-59aa-7667-a36c-1b4df4a9d5fd1" & @CRLF & _
"019311f0-89e5-7351-a230-01fab933711e" & @CRLF & _
"" & @CRLF & _
"01931z1e8-3ff1-718c-bb3d-cbe7211d3bb9" & @CRLF & _
"019311f0-59aa-7667-a36c-b4df4a9d5fd1" & @CRLF & _
"019311f0-89e5-7351-a230-01fab933711e" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"019311e8-3ffss1-718c-bb3d-cbe7211d3bb9" & @CRLF & _
"019311f0-59aa-7667-a36c-b4df4a9d5fd1" & @CRLF & _
"019311f0-89e5-7351-a230-01fab933711e" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")