import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9a-f]{8}(?:\\-[0-9a-f]{4}){3}-[0-9a-f]{12}$";
final String string = "019311e8-3ff1-718c-bb3d-cbe7211d3bb9\n"
+ "019311f0-59aa-7667-a36c-1b4df4a9d5fd1\n"
+ "019311f0-89e5-7351-a230-01fab933711e\n\n"
+ "01931z1e8-3ff1-718c-bb3d-cbe7211d3bb9\n"
+ "019311f0-59aa-7667-a36c-b4df4a9d5fd1\n"
+ "019311f0-89e5-7351-a230-01fab933711e\n\n\n"
+ "019311e8-3ffss1-718c-bb3d-cbe7211d3bb9\n"
+ "019311f0-59aa-7667-a36c-b4df4a9d5fd1\n"
+ "019311f0-89e5-7351-a230-01fab933711e\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}