$re = '/^[0-9a-f]{8}(?:\-[0-9a-f]{4}){3}-[0-9a-f]{12}$/m';
$str = '019311e8-3ff1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-1b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
01931z1e8-3ff1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
019311e8-3ffss1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);