use strict;
my $str = '019311e8-3ff1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-1b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
01931z1e8-3ff1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
019311e8-3ffss1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
';
my $regex = qr/^[0-9a-f]{8}(?:\-[0-9a-f]{4}){3}-[0-9a-f]{12}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}