import Foundation
let pattern = #"^[0-9a-f]{8}(?:\-[0-9a-f]{4}){3}-[0-9a-f]{12}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
019311e8-3ff1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-1b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
01931z1e8-3ff1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
019311e8-3ffss1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)