# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[0-9a-f]{8}(?:\-[0-9a-f]{4}){3}-[0-9a-f]{12}$"
test_str = ("019311e8-3ff1-718c-bb3d-cbe7211d3bb9\n"
"019311f0-59aa-7667-a36c-1b4df4a9d5fd1\n"
"019311f0-89e5-7351-a230-01fab933711e\n\n"
"01931z1e8-3ff1-718c-bb3d-cbe7211d3bb9\n"
"019311f0-59aa-7667-a36c-b4df4a9d5fd1\n"
"019311f0-89e5-7351-a230-01fab933711e\n\n\n"
"019311e8-3ffss1-718c-bb3d-cbe7211d3bb9\n"
"019311f0-59aa-7667-a36c-b4df4a9d5fd1\n"
"019311f0-89e5-7351-a230-01fab933711e\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.