// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9a-f]{8}(?:\-[0-9a-f]{4}){3}-[0-9a-f]{12}$").unwrap();
let string = "019311e8-3ff1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-1b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
01931z1e8-3ff1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
019311e8-3ffss1-718c-bb3d-cbe7211d3bb9
019311f0-59aa-7667-a36c-b4df4a9d5fd1
019311f0-89e5-7351-a230-01fab933711e
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}