#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w*)(?|\$`([^`]*)`|\$([^\s$]+))"
Local $sString = "qux$foo$bar" & @CRLF & _
"" & @CRLF & _
"qux$foo$bar; input$test$a$a" & @CRLF & _
"qux[["foo"]][["bar"]]; input[["test"]][["a"]][["a"]]" & @CRLF & _
"" & @CRLF & _
"qux$`foo`; bar$`baz`; x$uvw" & @CRLF & _
"qux[["foo"]]; bar[["baz"]]; x[["uvw"]]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"qux$`fo o`" & @CRLF & _
"q_ux$f_o_o$b.a_r"
Local $sSubst = "\1[["\2"]]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)