import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w*)(?|\\$`([^`]*)`|\\$([^\\s$]+))";
final String string = "qux$foo$bar\n\n"
+ "qux$foo$bar; input$test$a$a\n"
+ "qux[[\"foo\"]][[\"bar\"]]; input[[\"test\"]][[\"a\"]][[\"a\"]]\n\n"
+ "qux$`foo`; bar$`baz`; x$uvw\n"
+ "qux[[\"foo\"]]; bar[[\"baz\"]]; x[[\"uvw\"]]\n\n\n"
+ "qux$`fo o`\n"
+ "q_ux$f_o_o$b.a_r";
final String subst = "\\1[[\"\\2\"]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}