// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w*)(?|\$`([^`]*)`|\$([^\s$]+))").unwrap();
let string = "qux$foo$bar
qux$foo$bar; input$test$a$a
qux[[\"foo\"]][[\"bar\"]]; input[[\"test\"]][[\"a\"]][[\"a\"]]
qux$`foo`; bar$`baz`; x$uvw
qux[[\"foo\"]]; bar[[\"baz\"]]; x[[\"uvw\"]]
qux$`fo o`
q_ux$f_o_o$b.a_r";
let substitution = "\\1[[\"\\2\"]]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}