using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*)(?|\$`([^`]*)`|\$([^\s$]+))";
string substitution = @"\1[[""\2""]]";
string input = @"qux$foo$bar
qux$foo$bar; input$test$a$a
qux[[""foo""]][[""bar""]]; input[[""test""]][[""a""]][[""a""]]
qux$`foo`; bar$`baz`; x$uvw
qux[[""foo""]]; bar[[""baz""]]; x[[""uvw""]]
qux$`fo o`
q_ux$f_o_o$b.a_r";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}