re = /(\w*)(?|\$`([^`]*)`|\$([^\s$]+))/m
str = 'qux$foo$bar
qux$foo$bar; input$test$a$a
qux[["foo"]][["bar"]]; input[["test"]][["a"]][["a"]]
qux$`foo`; bar$`baz`; x$uvw
qux[["foo"]]; bar[["baz"]]; x[["uvw"]]
qux$`fo o`
q_ux$f_o_o$b.a_r'
subst = '\\1[["\\2"]]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result