package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w*)(?|\$`([^`]*)`|\$([^\s$]+))`)
var str = `qux$foo$bar
qux$foo$bar; input$test$a$a
qux[["foo"]][["bar"]]; input[["test"]][["a"]][["a"]]
qux$\`foo\`; bar$\`baz\`; x$uvw
qux[["foo"]]; bar[["baz"]]; x[["uvw"]]
qux$\`fo o\`
q_ux$f_o_o$b.a_r`
var substitution = "\1[["\2"]]"
fmt.Println(re.ReplaceAllString(str, substitution))
}