#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\S+)\s+(.*)\s+(\S+)$"
Local $sString = "100k melon 8" & @CRLF & _
"200 knife 7k" & @CRLF & _
"1.2m maple logs 19" & @CRLF & _
"42 the world's hardest-to-describe product may go here and you may even resort to 99 digits and more 5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")