using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+)\s+(.*)\s+(\S+)$";
string input = @"100k melon 8
200 knife 7k
1.2m maple logs 19
42 the world's hardest-to-describe product may go here and you may even resort to 99 digits and more 5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}