// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\S+)\s+(.*)\s+(\S+)$").unwrap();
let string = "100k melon 8
200 knife 7k
1.2m maple logs 19
42 the world's hardest-to-describe product may go here and you may even resort to 99 digits and more 5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}