import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+)\\s+(.*)\\s+(\\S+)$";
final String string = "100k melon 8\n"
+ "200 knife 7k\n"
+ "1.2m maple logs 19\n"
+ "42 the world's hardest-to-describe product may go here and you may even resort to 99 digits and more 5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}