const regex = /^(\S+)\s+(.*)\s+(\S+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+)\\s+(.*)\\s+(\\S+)$', 'gm')
const str = `100k melon 8
200 knife 7k
1.2m maple logs 19
42 the world's hardest-to-describe product may go here and you may even resort to 99 digits and more 5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}