use strict;
my $str = '100k melon 8
200 knife 7k
1.2m maple logs 19
42 the world\'s hardest-to-describe product may go here and you may even resort to 99 digits and more 5';
my $regex = qr/^(\S+)\s+(.*)\s+(\S+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}