#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\[url=\"([^\s"]+?)\"\](.+?)\[\/url\]"
Local $sString = "[url="https://wordpress.org/"]Обычная ссылка[/url]" & @CRLF & _
"[url="https://wordpress.org/" target="_blank"]Обычная ссылка в новом окне[/url]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")