using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[url=\""([^\s""]+?)\""\](.+?)\[\/url\]";
string input = @"[url=""https://wordpress.org/""]Обычная ссылка[/url]
[url=""https://wordpress.org/"" target=""_blank""]Обычная ссылка в новом окне[/url]";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}