re = /\[url=\"([^\s"]+?)\"\](.+?)\[\/url\]/
str = '[url="https://wordpress.org/"]Обычная ссылка[/url]
[url="https://wordpress.org/" target="_blank"]Обычная ссылка в новом окне[/url]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end